XPathmania installed but not showing up in menus

Topics: XPathmania
Jul 12, 2006 at 6:32 AM
I've got VS.NET 2005 Professional, but when I install XPathmania, I can't see it in my View->Other Windows menu item...

I can see the addin is installed when I go to Help->About, but I just can't access it.

Perhaps there's some registry key or other I can check?

Thanks!
Jul 12, 2006 at 11:18 AM
I've got the same issue, installed via the msi download but I cannot see the xpathmania window in view->other windows.

Any ideas

thanks
Steve
Coordinator
Jul 13, 2006 at 2:41 AM
I’m going to assume that you don’t have VSIP installed (you don’t have to, if you are just using the installer and didn’t want to compile the code yourself). If you open a command window and change the path to Visual Studio 2005 folder (usually C:\Program Files\Microsoft Visual Studio 8\Common7\IDE ) and run devenv.exe /setup it will tell Visual Studio to refresh all the install components (the XPathmania installer does this automatically), but I don’t think it will make a difference. The other thing you can check is to make sure that XPathmania was installed into the GAC, by checking to make sure it is listed in the Assembly Cache folder of the .Net Framework 2.0 configuration (found under the Administrative Tools for WinXP). It will be listed as XPathmania, version 1.0.2378.24251, public key token 637a304eea5087d5.

Jul 13, 2006 at 3:18 AM
I noticed it ran devenv after installation, so I haven't tried that. But when I checked the GAC, I saw that it actually has version 1.0.2378.35894 (public key token is 637a304eea5087d5) so maybe that's the issue?
Coordinator
Jul 13, 2006 at 12:54 PM
My mistake on the version number, as I got that version number from a machine with an older build. 1.0.2378.35894 is the correct build number, and that is what I should have put in the original post.

As far as registry entries you should have the following 4 entries:

HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\InstalledProducts\XPathmania
"Package"="{2e2c89a9-57e5-449f-9ad4-90080323d62c}"
@="#100"
"ProductDetails"="#102"
"PID"="1.0"
"LogoID"="#400"

HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\Packages\{2e2c89a9-57e5-449f-9ad4-90080323d62c}
@="XmlMvp.XPathmania.XPathmania, XPathmania, Version=1.0.2378.35894, Culture=neutral, PublicKeyToken=637a304eea5087d5"
"InprocServer32"="C:\\WINDOWS\\system32\\mscoree.dll"
"Class"="XmlMvp.XPathmania.XPathmania"
"Assembly"="XPathmania, Version=1.0.2378.35894, Culture=neutral, PublicKeyToken=637a304eea5087d5"

HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\Menus
"{2e2c89a9-57e5-449f-9ad4-90080323d62c}"=", 1000, 1"

HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\ToolWindows\{7190d388-efff-4101-bb33-9d83861d7d0b}
@="{2e2c89a9-57e5-449f-9ad4-90080323d62c}"
"Name"="XmlMvp.XPathmania.XPathToolWindow"
Jul 17, 2006 at 2:14 AM
I checked the registry, and the following key had the wrong version number:

HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\Packages\{2e2c89a9-57e5-449f-9ad4-90080323d62c}
@="XmlMvp.XPathmania.XPathmania, XPathmania, Version=1.0.2378.35894, Culture=neutral, PublicKeyToken=637a304eea5087d5"

I changed it to the right one, re-ran "devenv /setup" and ... it still didn't work :(
Coordinator
Jul 19, 2006 at 12:33 PM
Dean,

Can you email me directly at don at donxml dot com. I'd like to see if I can figure out what is so different about your machine that XPathmania will not show in VS.

Don
Jul 19, 2006 at 7:27 PM
I am also having the same issues. I have made the change to the registry as well but it is still not working. Any ideas? Other add-ins I have installed include CopySourceAsHTML2005, DevExpress Tools, and GhostDoc. Beyond that I can't think of anything else that could cause a problem.

Rich
Jul 21, 2006 at 2:15 PM
I get the following message with vs.net when clicking on the xpathmania other window option

Package Load failure - packacge xmlmvp.xpathmania bla bla failed to load properly.please contact package vendor for assistance


any ideas???
Coordinator
Jul 30, 2006 at 4:54 PM
I have tried to reproduce the Menu issue, but have failed, so far. I thought it might have to do with a hotfix that ReSharper installs, but after building a clean machine in VPC and installing ReSharper, I can't reporduce the error. I'm going to retry with a couple other options, but for now, this still baffles me.
Aug 1, 2006 at 3:00 AM
Don,

I think I may have missed your follow-up. Any further progress on this?
Sep 13, 2006 at 8:23 PM
Hi Don,

I too am having this issue. I have checked the registry, GAC, and ran devenv.exe /setup. Everything checks out, except the menu item is not available in view-->Other Windows. Has this been solved?

Thanks,

Primate
Coordinator
Sep 16, 2006 at 5:16 PM
I've tried to reproduce this error on a clean VPC image, and have not been able to recreate this. At one time I though it might have something to do with a Visual Studio 2005 Patch ReSharper installs, but even with installing ReSharper with, and without the patch I haven't been able to reproduce it. So far, out of all the downloads and installs, I only know of 3 people with this problem, and no one can figure out what is special about their machines.

Any additional info people can provide would be great.

Don
Sep 29, 2006 at 12:14 AM
Hi Don.

Add me to the list. The menu item isn't showing up for me either.

My install of Visual Studio (Team Suite) is pretty clean, I've added the following thou...

Team Foundation PowerToys 1.0
CopySourceAsHtml Addin

Cheers,

Kev

Oct 12, 2006 at 11:41 AM
Me too. I have XmlMvp.XpathMania in my about list, with all keys in the proper way, The XPathMania appears in the GAC, yet nohting appears.
The same problem I still have with Axosoft OnTime for VS.NET 6.1.2.6397

Does maybe bring some problem having VS open during the installation? something maybe goes wrong with configuration during shutting down.
Oct 12, 2006 at 11:48 AM
I wuold amend: I found it in Menu>>View>>Other windows
thanks a lot, I'll try it
Oct 12, 2006 at 6:36 PM
Don:

Sorry to say, I don't see the window either.
My registry settings check out, and XPathMania is in the about-list, but the window's a no-show.

Josh
Oct 23, 2006 at 7:01 AM
Im am having the same problem. I checked GAC, registry and they were OK.
I have VS2005 Professional installed with VS2005 SP1 beta.
I do not have any other add-ins.

The packages entry had wrong version number in the default value string key but I guess that this is just a comment? The value was:
@="XmlMvp.XPathmania.XPathmania, XPathmania, Version=1.0.2340.32724, Culture=neutral, PublicKeyToken=637a304eea5087d5"
In all other places the version was correct (1.0.2378.35894).
I fixed then version and run devenv but no effcet.
Feb 28, 2007 at 10:31 AM
Im having this issue as well on a fully patched vs 2005 professional. Currently I have installed the powertoys for visual studio - Resource Refactoring Tool,VSCmdShelll along with Microsoft Printform Component, Developer Express DXCore and Refactor! Ive actually had xpathmaia up andrunning on a previous install on this machine but for some reason its not going now. I know 4 sure that i didnt have Microsoft Printform Component, Developer Express DXCore and Refactor! before but im not sure how relevant that would be to this issue.
Coordinator
Mar 6, 2007 at 1:10 AM
I'm working on an updated version that uses the new VS SDK v4. Hopefully it will help resolve some of these issues.
Mar 8, 2007 at 11:21 PM
Is this project still active? If so, how do I install this? I see references to an MSI, but I couldn't find one on this site.
Coordinator
Apr 16, 2007 at 9:30 PM

camainc wrote:
Is this project still active? If so, how do I install this? I see references to an MSI, but I couldn't find one on this site.


Yes, it is active. Go to the Releases section and download the XPathmania RC. You can get either the code, or the installer.
Apr 19, 2007 at 5:44 PM
Edited Apr 19, 2007 at 5:51 PM
I fixed it!!!!!!!!!!!!!!!!

I too was having the same problem...with the View->Other Windows and the add-in not showing up. I did a number of things at one time so I am not 100% sure what did it. I will list what I did in order of likelihood of solving the problem:

1. Modified HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\Packages\{2e2c89a9-57e5-449f-9ad4-90080323d62c} so that "InprocServer32"="C:\\WINDOWS\\system32\\mscoree.dll" points to the proper DLL. I have my windows install in C:\WINXP so I had to modify InprocServer32 to C:\WINXP\system32\mscoree.dll.

2. Copied XPathmania.dll from the GAC to C:\Program Files\MvpXml\XPathmania1.0\.

3. Modified HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\8.0\Packages\{2e2c89a9-57e5-449f-9ad4-90080323d62c} to fix the Version information as already pointed out in earlier posts.

4. Installed the VS SDK v4 http://affiliate.vsipmembers.com/affiliate/downloadFiles.aspx.

I am pretty sure, item 1 is what solved the problem. Of course, you will need to exit and re-run Visual Studio in order for it to load the modified registry settings. You may need to do a devenv /setup or a devenv /resetskippkgs at the command line after that fix.

Jason Nadrowski
http://blogs.informationhub.com/jnadrowski/
Coordinator
Apr 24, 2007 at 1:29 AM
Thanks Jason! I'm sure #1 and #2 were problems, as the installer is suppose to put the XPathmania.dll in the GAC. I'm not sure why this didn't happen. The only thing that should be in the MVPXML\Xpathmania1.0 folder is the XPathmania.CustomActionInstaller.dll.

I've downloaded the VS SDK 4, and upgraded the project to V4. I just have to check everything in and do a build and I'll release it to the pubic.

Don
Jul 5, 2007 at 6:55 PM
I installed today, and not only is XPathmania.dll not in the GAC, it's not anywhere on my PC, so I can't manually add it to the GAC.

It's a shame that this is still a problem, because it looks like a great tool, and I was looking forward to trying it out (I'm not quite excited enough about it to download the source code and install the VS SDK to try to make it work, though).
Oct 7, 2007 at 5:01 PM
Hi folks,

I just installed XPathMania today and (You guessed it !)... couldn't find the View - > Other windows -> XpathMania item. After searching the net a bit, I found this forum thread. Thanks to the suggestions of the posters before me, I was able to fix the problem.

My situation :
  1. XPathMania listed in Help -> About.
  2. XPathMania.dll was present in the GAC and had the correct version no. and Token.
  3. Checked Registry, all entries okay, except
    • The version no. was incorrect under HKEYLOCALMACHINE\Software\Microsoft\VisualStudio\8.0\Packages\{2e2c89a9-57e5-449f-9ad4-90080323d62c} . It was an older version. (sorry, I didn't keep that number.)
    • The path to mscoree.dll was incorrect, since I have Windows 2003 installed at D:\Windows.

After correcting these 2 registry problems and running "devenv /setup", I was successful at launching XPathMania !!

Don, I hope this info helps you to identify the problems.

My suggestions :
  • Please include atleast a Readme.txt file with basic instructions about the utility. Such as how to launch XPathMania within VS.
  • I presume that the path to Windows might be hardcoded, that's why the error in the registry. Retrieving the path during installation might help. I also wonder why it's adding an older version no. into the registry.

Thanks for this fabulous Addin,
BTW, this is a great utility and I'm eager to use it regularly.
Regards,
C.